Flow Temp Sensor SEN-FM18T10 stopped working with RP-1250

Complete water cooling systems (for example: Exos-2.5, PC5-1336, etc.)...
SpecialEd
Water Pistol Grunt
Water Pistol Grunt
Posts: 2
Joined: Fri Aug 22, 2014 2:58 pm
Contact:

Flow Temp Sensor SEN-FM18T10 stopped working with RP-1250

Postby SpecialEd » Fri Aug 22, 2014 3:10 pm

I have an RP-1250 with the SEN-FM18T10 Flow Rate Meter and Temp Sensor plugged in, my whole loop is laid out as such:

RP1250 -> SEN-FM18T10 -> CPU -> Rad -> RAM -> Rad -> PMP-400/Reservoir -> 3x GPU -> RP1250

Note: Tubing used in between each part listed above is Clear Vinyl Tubing 1/4"ID 3/4" OD purchased from my local Lowe's Home Improvement store.

The setup worked great for a long time, the sensor was actually positioned up towards the roof of the case behind the radiator as to be out of view. It was positioned horizontally and the flow direction matched the arrow on the device.

After around six months it started to display a flow rate of 0.0 LPM, however by disconnecting my Koolance Quick DIsconnect valves (which forces a little air into the loop when re-connecting) that the flow was definitely not 0.0 LPM.

At this point I disconnected everything, cleaned out the blocks and radiators with distilled water, replaced the tubing and reconnected. Sure enough the flow rate came back to life.

Fast forward a couple weeks later and it was back to 0.0 LPM. I tried changing the RP-1250's settings for the flow rate meter to FM-16 as well as changing the tube sizes, neither of which yielded any results.

Today in the mail I received a brand new SEN-FM18T10, plugged it in and everything works fine again.

I did notice the new sensor's propeller spins if i lightly tap it with a precision screwdriver, however the old one appears to be jammed.

My question is, what did I do to break the original and how can I prevent this from happening to my new one? Also is there anything I can do to repair the old one?

Ace0751
Fire Hydrant Gunner
Fire Hydrant Gunner
Posts: 452
Joined: Sat Apr 09, 2011 8:12 am
Location: Cleveland, Ohio
Contact:

Re: Flow Temp Sensor SEN-FM18T10 stopped working with RP-125

Postby Ace0751 » Sat Aug 23, 2014 6:17 pm

The problem with the models after the FM16, the fins are to thin and will snap or stop working easily which will result in 0.0. I had a FM17 that I never used and was still in the box, went to take it out a few months back and one of the fins was broke. There is nothing you can do really to make the old meter work again. The best thing you can do is maybe clean out the rad and block so no components in them will jam it up cause any little particle in the loop will easily jam those new meters. My opinion is pick up some FM16 yes they are not the ideal meters but they don't break down as easily as the new meters. Had my FM16s for two years now and never had one issue with them yet.

Another problem with the FM17 is the way is passes the liquid through the fins cause it has such a small window to flow through.
GIGABYTE X58-UD7 Mobo Rev. 2
Intel i7 950 3.25Ghz
Corsair DOMINATOR GT 12GB 2000mhz DDR3
MSI Radeon 290X
Danger Den Customized Case


Return to “Water Cooling Systems & Kits”

Who is online

Users browsing this forum: No registered users and 2 guests