Connecting Swiftech MCP655-PWM to TMS-205?

Pumps and reservoirs
Kinst VonSterga
Water Pistol Grunt
Water Pistol Grunt
Posts: 14
Joined: Sun Jun 21, 2009 1:13 pm
Contact:

Connecting Swiftech MCP655-PWM to TMS-205?

Postby Kinst VonSterga » Wed Feb 12, 2014 2:30 am

I have a MS-205 + Swiftech MCP655-PWM-Drive http://www.frozencpu.com/products/17549/ex-pmp-214/Swiftech_MCP655-PWM-DRIVE_12v_Water_Pump_Module_-_PWM_Enabled_Single_Version.html#blank.

The pump has a standard 4 pin/molex power connector (2 of the 4 nodes are wired) and a PWM 4-Pin Header (2 of the 4 pins are wired).

The TMS-205's pump connector is made for a 3-pin header and I can't put the 4-pin head onto it, as the barb for the adjoining ATX connector is in the way.

Since 4-pin header only used the far right (2 pins), I replaced this head with a 3 pin-head, wiring the same far right 2 pins.

Placing the 3-pin header onto the TMS-205, there seem be no controlling the pump speed, nor is it reading any RPMs. Do I have the wires connected to the wrong pump-pin on the TMS-205?

http://koolance.com/image/cache/data/products/tms-205_p1-700x700.jpg
Case: Lian Li PC4-1025
MB: EVGA SLI-Classified Copper Block Ed. P/N 769
CPU: Intel i7 extreme 965
RAM: 12GB OCZ DDR3 PC3
GPU: MSI HD 6990 + VID-AR597
Rad: Monster Extreme
Pump:Eheim XT Ultra Acquastream
PSU: Antec Quattro 1000W
OS: Win7 x64 Ultimate

Izerous
Rain Maker
Rain Maker
Posts: 1179
Joined: Tue Sep 16, 2008 10:34 am
Location: Edmonton, Canada
Contact:

Re: Connecting Swiftech MCP655-PWM to TMS-205?

Postby Izerous » Wed Feb 12, 2014 9:22 am

3 pin headers are for flat volt/amp power leveling, PWM works in a completely different fashion to control/report speed. If the pump is designed for PWM signals it will not work with a 3 pin header.
Corsair 800D
2xPMP-450S > Amd FX8370 > Asus CH4-EX > AMD 6990 > AMD 6990 > 2x1080 rads > return
32GB Ram

Kinst VonSterga
Water Pistol Grunt
Water Pistol Grunt
Posts: 14
Joined: Sun Jun 21, 2009 1:13 pm
Contact:

Re: Connecting Swiftech MCP655-PWM to TMS-205?

Postby Kinst VonSterga » Wed Feb 12, 2014 5:59 pm

Thanks ... I reverted back to the 4-pin header on the pump and plugged it into the 4-pin CPU fan and all is well (controlling the pump speed from the MB/CPU temp monitor and fan controll). So the bottom line is that the TMS-205 isn't designed to control PWM fans and/or pumps, only variable volt/amp devices.
Case: Lian Li PC4-1025
MB: EVGA SLI-Classified Copper Block Ed. P/N 769
CPU: Intel i7 extreme 965
RAM: 12GB OCZ DDR3 PC3
GPU: MSI HD 6990 + VID-AR597
Rad: Monster Extreme
Pump:Eheim XT Ultra Acquastream
PSU: Antec Quattro 1000W
OS: Win7 x64 Ultimate


Return to “Pumps & Reservoirs”

Who is online

Users browsing this forum: No registered users and 1 guest