RP-985 Display/Buttons Not Working

Pumps and reservoirs
Redsponge
Water Pistol Grunt
Water Pistol Grunt
Posts: 1
Joined: Sat Apr 12, 2014 5:01 pm
Contact:

RP-985 Display/Buttons Not Working

Postby Redsponge » Sat Apr 12, 2014 5:21 pm

To start off I have had my RP-985 (not a rev2), for about 4-5 years. Today while playing a game my temperature alarm started beeping (2 of the probes are attached to my video cards). They were set a little low for the game I was playing so I held down the up and down arrow buttons to change the temperature (while it was beeping). I increased the temperature at which to warn at and the beeping had stopped. However once the display returned to normal the display went blank and only the up arrow button made any noise; the others did not beep when pushed.

I tried powering off my computer (shutdown and remove power), then powering up with no luck. Eventually I started trying stress tests on my video cards to see if it will start alerting that the temperature is too high; I was in luck it did start beeping. However their still was not any display. When I held down the up and down arrow buttons the display came back and I was able to change the warning temperature. Just like before though once the display was supposed to return to the actual temperature the display went blank again.

This time when it started to warn again I pushed the up and down arrow buttons and when the display came up I held down the temperature c/f button to reset the settings. Once it reset the display came back and everything was working. Since it was reset I had to change the temperature settings again. Once it was changed and it was suppose to change back to the regular temperature screen, the display went blank and this time none of the buttons worked and the pump power went to 100%.

This is where I am stuck at; no display, no input from the buttons, no alarms when the temperature gets to high.

Is their any way to get it to reset back to the factory settings (possibly a small battery inside the unit)? I am going to assume right now that it is a glitch in the units software and not a hardware issue.

TLDR: RP-985 no display, no input from buttons

Izerous
Rain Maker
Rain Maker
Posts: 1179
Joined: Tue Sep 16, 2008 10:34 am
Location: Edmonton, Canada
Contact:

Re: RP-985 Display/Buttons Not Working

Postby Izerous » Mon Apr 14, 2014 12:33 pm

While this may not work, it is worth at least trying as it will solve some capacitor charge issues. Capacitors and other electronics can hold a charge for a period of time. To purposely force the caps to drain...

-turn off the computer properly
-unplug the power supply from the wall (either the cable from the wall or the PSU) but if your PSU has an on/off switch leave it in the on position.
-attempt to turn the computer on
-Everything should light up just for a fraction of a second as it pull all the remaining power from the existing capacitors in the PSU, motherboard and other components.
-Then plug it back in and attempt to power up properly.

I don't remember if the RP units have caps in them to drain but this trick can sometimes work for finicky motherboards etc.
Corsair 800D
2xPMP-450S > Amd FX8370 > Asus CH4-EX > AMD 6990 > AMD 6990 > 2x1080 rads > return
32GB Ram


Return to “Pumps & Reservoirs”

Who is online

Users browsing this forum: No registered users and 1 guest