COV-RP450 Coupler Leaking... Help

Pumps and reservoirs
Hercules331
Water Pistol Grunt
Water Pistol Grunt
Posts: 1
Joined: Sun Jun 08, 2014 4:08 am
Contact:

COV-RP450 Coupler Leaking... Help

Postby Hercules331 » Sun Jun 08, 2014 6:45 am

So I recently purchased a D5 pump, COV-RP450, and 50mm tall reservoir. After putting the 3 pieces together and testing out the system, water is constantly leaking from where the reservoir coupler connects into the pump top. It leaks out slowly and I've tried tightening everything down loosely and tightly and it still leaks. I thought maybe it was the force of the pump making it leak so I reassembled everything and just let it sit with water in it.... and it still starts to leak, even with the pump off. I looked at the O-ring and coupler and it doesnt look like theres any defects. Water doesnt seem to be leaking out where the reservoir connects into the coupler, so thats good. Has anyone had this issue before? Could something be wrong with my O-ring? Is there something I am missing, is there a trick to getting it not to leak? You can see in the images (attached) where it is leaking. Any advice is much appreciated. Thanks.
Attachments
20140608_192531.jpg
Leaking from where the reservoir coupler connects into the pump top (COV-RP450)
(129.03 KiB) Not downloaded yet
20140608_192622.jpg
Leaking from where the reservoir coupler connects into the pump top (COV-RP450)
(247.7 KiB) Not downloaded yet

alejandro1254
Water Pistol Grunt
Water Pistol Grunt
Posts: 10
Joined: Mon Sep 09, 2013 8:01 am
Contact:

Re: COV-RP450 Coupler Leaking... Help

Postby alejandro1254 » Mon Jan 26, 2015 6:49 am

I would try to put some Teflon tape on that thread


Return to “Pumps & Reservoirs”

Who is online

Users browsing this forum: No registered users and 1 guest